$re = '/\s.+?$/m';
$str = 'DL666 DL777 DL888 这波值不值你下载';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);