re = /(?:[\£\$\€]{1}[,\d]+.?\d*)/
str = 'I bought a car $12,250,000 it was expensive
that thing was £14,500,123.125521 dollas
afsaf£120.25sfsafsa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end