$re = '/:\s*([a-z\s-]*?)\s*year/m';
$str = 'history: four year-old boy was really sad when he found
out the toy was broken';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);