#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s{8}/.*?(/.*?)?/(.*?):\d+\s{$"
Local $sString = "ltm pool /Common/ActiveDirectory_Pool {" & @CRLF & _
" members {" & @CRLF & _
" /Common/hodcdcgw01:389 {" & @CRLF & _
" address 10.6.15.21" & @CRLF & _
" priority-group 3" & @CRLF & _
" }" & @CRLF & _
" /Common/hodcdcgw02:389 {" & @CRLF & _
" address 10.6.15.22" & @CRLF & _
" priority-group 3" & @CRLF & _
" }" & @CRLF & _
" /Common/hodcdcgw04-1:389 {" & @CRLF & _
" address 10.6.15.207" & @CRLF & _
" priority-group 3" & @CRLF & _
" }" & @CRLF & _
" /Common/wkdcadrw02:389 {" & @CRLF & _
" address 10.6.66.21" & @CRLF & _
" priority-group 1" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" min-active-members 1" & @CRLF & _
" monitor /Common/bmdp_tcp " & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")