$re = '/^\s{8}/.*?(/.*?)?/(.*?):\d+\s{$/m';
$str = 'ltm pool /Common/ActiveDirectory_Pool {
members {
/Common/hodcdcgw01:389 {
address 10.6.15.21
priority-group 3
}
/Common/hodcdcgw02:389 {
address 10.6.15.22
priority-group 3
}
/Common/hodcdcgw04-1:389 {
address 10.6.15.207
priority-group 3
}
/Common/wkdcadrw02:389 {
address 10.6.66.21
priority-group 1
}
}
min-active-members 1
monitor /Common/bmdp_tcp
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);