using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<start>\d+)[\s\-_]+(?:(?:\w+[\s\-_]+)?(?P<end>\d+)[\s\-_]+)?";
string input = @"10407_10415_10416_Autopath_DATA_SUMMARY.xlsm.From_Applicant.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}