import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<start>\\d+)[\\s\\-_]+(?:(?:\\w+[\\s\\-_]+)?(?P<end>\\d+)[\\s\\-_]+)?";
final String string = "10407_10415_10416_Autopath_DATA_SUMMARY.xlsm.From_Applicant.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}