const regex = new RegExp('10\\.100\\.([1-9]\\d*|\\d{2,})\\.([^1]$|\\d{2,})', 'gm')
const str = `10.100.0.11
10.100.1.12
10.100.11.4
10.100.44.1
10.100.10.4
10.100.02.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}