import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>(\\b(?:(?:[0-9]{7}|[0-9]{10,11})|[a-zA-Z][0-9]{10})\\b)[^\\r\\n]*?(\\b(?:\\d{1,2}|(?:(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember|(?:t\\.?|\\.))?|Oct(?:ober|\\.)?|Nov(?:ember|\\.)?|Dec(?:ember|\\.)?)))(?:[^A-Za-z0-9\\v](?:\\d{1,2})\\,?[^A-Za-z0-9\\v](?:\\d{2}|\\d{4})|[^A-Za-z0-9\\v\\.](?:(?:\\'|\\`)\\d{2}|\\d{4}))\\b)[^\\r\\n]*?(\\$\\d+[\\.\\,\\d]*)[^\\r\\n]*?($))|(?2)[^\\r\\n]*?(?:(?1)|(?3))[^\\r\\n]*?(?4)|(?1)[^\\r\\n]*?(?:(?2)|(?3))[^\\r\\n]*?(?4)|(?3)[^\\r\\n]*?(?:(?1)|(?2))[^\\r\\n]*?(?4)";
final String string = "9991110022 9/4/2019 9/12/2019 $10403.33\n"
+ "10/2/2019 11/2/2019 33300011113 $130.30\n"
+ "12200013131 Nov. 2, 2019 $45,300.32\n"
+ "9991110022 9/4/2019 9/12/2019 $10403.33\n"
+ "$492,300 10/2/2019 11/2/2019 33300011113\n"
+ "5/3/2019 $500.30\n"
+ "12200013131 Nov. 2, 2019 $45,300.32";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}