#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![a-z:])name:|:name(?![a-z:])"
Local $sString = "name: | :name | name:`asdf`" & @CRLF & _
"" & @CRLF & _
"But should not match any of these:" & @CRLF & _
"" & @CRLF & _
":name: " & @CRLF & _
"eman: " & @CRLF & _
"nnamee: " & @CRLF & _
":nameasdfj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")