$re = '/(?<![a-z:])name:|:name(?![a-z:])/m';
$str = 'name: | :name | name:`asdf`
But should not match any of these:
:name:
eman:
nnamee:
:nameasdfj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);