import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z].*(?:\\n+[a-zA-Z].*)*(?=\\n+\\d{6,}$)";
final String string = "27223525\n\n"
+ "West Food Group B.V.9\n\n"
+ "52608670\n\n"
+ "Westcon\n\n"
+ "Group European Operations Netherlands Branch\n\n"
+ "30221053\n\n"
+ "Westland Infra Netbeheer B.V.\n\n"
+ "27176688\n\n"
+ "Wetransfer 85 B.V.\n\n"
+ "34380998\n\n"
+ "WETRAVEL B.V.\n\n"
+ "70669783";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}