$re = '/^(?=.*(?:[A-Za-z].*\d|\d.*[A-Za-z]))[A-Za-z0-9]{10,50}$/m';
$str = 'foobarasdaasdsa12asdsd
foobarspamasdasdasf
13234454556666
12335345asasff
sadfkajfkaskfhsdklfhjkashfjasjasdhjash123243453667786
adas434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);