$re = '/(\S+)=["\']?((?:.(?!["\']?\s+(?:\S+)=|[>"\']))+.)["\']?/m';
$str = '<name attribute=value attribute="value" attribute=\'value\'>CDAT! dfg abc="ddd" <name attribute=value attribute="value" attribute=\'value\'>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);