re = /(?<=Phrase A: ).*[\r\n]+\KPhrase A: /m
str = 'Phrase A: Words
Phrase A: Words
Phrase A: Words
Phrase B: Words
Phrase B: Words
Phrase A: Words
Phrase A: Words
Phrase B: Words
Phrase A: Words
Phrase A: Words
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end