$re = '/(?<!\S)Hello(?=[!,.\s]|$)/m';
$str = 'If you test Hello, Hello!, Hello or Hello it returns true as expected.
If you test .Hello, aHello or Helloa it returns false as expected.
However I have two problems:
It returns true if you pass it Hello:, Hello?, Hello) etc. which is not what I want, only !, , , . should be allowed.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);