const regex = new RegExp('(?<!\\S)[a-zA-Z]*[:/]*[\\w-]+\\.+[\\w:./%&=?-]+(?!\\S)', 'gm')
const str = `test@test.com
test example@example.com
example@example.co.uk
test
www.test.com
example.com
www.example.com
test sub.example.com test
http://example.com
test http://www.example.com test
http://sub.example.com
https://example.com
https://www.example.com
https://sub.example.com
git://github.com/user/project-name.git
irc://test.test.com:8080/test test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}