$re = '/^\w+(?:-\w+)*(?:\s+\w+(?:-\w+)*){2}/m';
$str = 'This is cat. It is fat. That is a dog. It looks like a log. Fat-cat dog_log
This is Fat-cat dog_log. It is fat. That is a dog. It looks like a log.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);