re = /{[^}]+}/m
str = 'Revenue for the period is {value="32", font="34"} and EBITDA is {value="12", font="34"} for 2022
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end