use strict;
my $str = ' january 23rd 2011
2004 / 03 / 12
1/12/2014 16-12-04
feb 18 1970
2014.2.24
12-12-12
2nd 12 2004
1st Feb 2008
2001-09-11
2001 Sep 11
sep-jan 2000
mar
';
my $regex = qr/(?=\b(jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec|\d{4}|\d{1,2}))\w*[\t\ \\\/\.\,\;\:\-\+\_]+(\d{1,2}|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)\w*[\t\ \\\/\.\,\;\:\-\+\_]+(\d{4}|\d{1,2})\w*\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}