import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(For|From).*$";
final String string = "The Consequences of Hostilities Between the States\n\n"
+ "From the New York Packet.\n\n"
+ "Tuesday, November 20, 1787.\n\n"
+ "HAMILTON\n\n"
+ "To the People of the State of New York:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}