const regex = /^(For|From).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(For|From).*$', 'gm')
const str = `The Consequences of Hostilities Between the States
From the New York Packet.
Tuesday, November 20, 1787.
HAMILTON
To the People of the State of New York:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}