re = /^(For|From).*$/m
str = 'The Consequences of Hostilities Between the States
From the New York Packet.
Tuesday, November 20, 1787.
HAMILTON
To the People of the State of New York:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end