# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*([\w ^?.]*?)\*/<em>\1<\em>/g;t' <<< "Chicken teriy*ai*ki r*ai*men noodles, spaghetti a la moneg*ai*sque.
^*Have I seen^ you before?*"