#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\*([\w ^?.]*?)\*"
Local $sString = "Chicken teriy*ai*ki r*ai*men noodles, spaghetti a la moneg*ai*sque." & @CRLF & _
"" & @CRLF & _
"^*Have I seen^ you before?*"
Local $sSubst = "<em>\1<\em>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)