package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*([\w ^?.]*?)\*`)
var str = `Chicken teriy*ai*ki r*ai*men noodles, spaghetti a la moneg*ai*sque.
^*Have I seen^ you before?*`
var substitution = "<em>\1<\em>"
fmt.Println(re.ReplaceAllString(str, substitution))
}