use strict;
my $str = 'Chicken teriy*ai*ki r*ai*men noodles, spaghetti a la moneg*ai*sque.
^*Have I seen^ you before?*';
my $regex = qr/\*([\w ^?.]*?)\*/p;
my $subst = '<em>\\1<\\em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";