#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0{3})(?!6{3})[0-8]\d{2}-(?!0{2})\d{2}-(?!0{4})\d{4}$"
Local $sString = "762-37-6334" & @CRLF & _
"429-08-8462" & @CRLF & _
"519-75-9429" & @CRLF & _
"117-08-6495" & @CRLF & _
"544-12-9823" & @CRLF & _
"841-01-5655" & @CRLF & _
"494-82-9724" & @CRLF & _
"568-11-2312" & @CRLF & _
"420-42-8078" & @CRLF & _
"396-09-7229" & @CRLF & _
"869-57-0924" & @CRLF & _
"609-44-0934" & @CRLF & _
"578-20-1520" & @CRLF & _
"835-87-3325" & @CRLF & _
"636-03-4578" & @CRLF & _
"482-19-1418" & @CRLF & _
"364-60-1676" & @CRLF & _
"780-23-8549" & @CRLF & _
"265-33-9416" & @CRLF & _
"221-88-6838" & @CRLF & _
"550-13-2720" & @CRLF & _
"336-93-2610" & @CRLF & _
"193-47-3307" & @CRLF & _
"480-82-8373" & @CRLF & _
"750-66-0817" & @CRLF & _
"122-68-3192" & @CRLF & _
"673-84-7164" & @CRLF & _
"191-03-8274" & @CRLF & _
"412-41-9768" & @CRLF & _
"888-21-9775" & @CRLF & _
"805-53-9154" & @CRLF & _
"150-26-0934" & @CRLF & _
"880-42-1378" & @CRLF & _
"853-41-1922" & @CRLF & _
"467-22-3453" & @CRLF & _
"220-91-4157" & @CRLF & _
"657-24-3167" & @CRLF & _
"229-17-5111" & @CRLF & _
"411-38-6337" & @CRLF & _
"453-61-4836" & @CRLF & _
"123-27-0915" & @CRLF & _
"105-56-0050" & @CRLF & _
"646-82-7847" & @CRLF & _
"105-17-8892" & @CRLF & _
"301-70-3833" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")