package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^-]+)(?:-[^-]+){3}$`)
var str = `here-are-some-words-to-try
a-b-c-d-e-f-g-h-i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}