# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\h([a-zA-Z0-9]{8})$(?=.*\h\1$)/$1/gm;t' <<< "Folder A\Folder C\File three.txt 56efd95f
Folder A\File one.txt b8e1b873
Folder A\Folder B\Folder D\File four.txt 56efd95f
Folder A\Folder B\File two.txt 21e8e9c9"