import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\h([a-zA-Z0-9]{8})$(?=.*\\h\\1$)";
final String string = "Folder A\\Folder C\\File three.txt 56efd95f\n"
+ "Folder A\\File one.txt b8e1b873\n"
+ "Folder A\\Folder B\\Folder D\\File four.txt 56efd95f\n"
+ "Folder A\\Folder B\\File two.txt 21e8e9c9";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}