re = /^
(?=.*?\bone\b)
(?=.*?\btwo\b)
(?=.*?\bthree\b)
(?!\t.*?)
.*
$/xm
str = 'only if line contauins one two three it matches
only if line contauins one two three it matches and has no tabs " "
here two whatever
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end