using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MatchesBlock[^\{]+\K(.*})";
string substitution = @"$1$2$3";
string input = @"""var block = new MatchesBlock('page_competition_1_block_competition_matches_summary_5', 'block_competition_matches_summary', {""page"":0,""bookmaker_urls"":{""13"":[{""link"":""http:\/\/www.bet365.com\/home\/?affiliate=365_178981"",""name"":""Bet 365""}]},""block_service_id"":""competition_summary_block_competitionmatchessummary"",""round_id"":42011,""outgroup"":false,""view"":2,""competition_id"":13});""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}