#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^k[a-z0-9]{9}$|^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64}).kst$"
Local $sString = "hugepoopy.kst" & @CRLF & _
"buy@hugepoopy.kst" & @CRLF & _
"buy_many@hugepoopy.kst" & @CRLF & _
"buy@many@hugepoopy.kst" & @CRLF & _
"buy.many@hugepoopy.kst" & @CRLF & _
"hugepoopy.tst" & @CRLF & _
"huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst" & @CRLF & _
"" & @CRLF & _
"khugepoopy" & @CRLF & _
"buy@khugepoopy" & @CRLF & _
"khuuugepoopy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")