const regex = /^k[a-z0-9]{9}$|^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64}).kst$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^k[a-z0-9]{9}$|^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64}).kst$', 'gmi')
const str = `hugepoopy.kst
buy@hugepoopy.kst
buy_many@hugepoopy.kst
buy@many@hugepoopy.kst
buy.many@hugepoopy.kst
hugepoopy.tst
huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst
khugepoopy
buy@khugepoopy
khuuugepoopy`;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}