Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^k[a-z0-9]{9}$|^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64}).kst$
/
gmi
Input 1
1
New
hugepoopy.kst buy@hugepoopy.kst buy_many@hugepoopy.kst buy@many@hugepoopy.kst buy.many@hugepoopy.kst hugepoopy.tst huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst khugepoopy buy@khugepoopy khuuugepoopy