// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^k[a-z0-9]{9}$|^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64}).kst$").unwrap();
let string = "hugepoopy.kst
buy@hugepoopy.kst
buy_many@hugepoopy.kst
buy@many@hugepoopy.kst
buy.many@hugepoopy.kst
hugepoopy.tst
huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst
khugepoopy
buy@khugepoopy
khuuugepoopy";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}