#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^.* you.*$"
Local $sString = "4" & @CRLF & _
"00:00:24.067 --> 00:00:35.924" & @CRLF & _
"Hi, how are you?" & @CRLF & _
"Doing fine?" & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"00:00:35.926 --> 00:00:47.264" & @CRLF & _
"I'm doing the best I can." & @CRLF & _
"And you?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")