using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[0-9]{12,})[a-zA-Z0-9)(,'-/\&.#? ]*$";
string input = @"frf 6666666666996 ere
88888888888
888888888888
8888888888888";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}