#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "public (?:.*?) (.*)"
Local $sString = "private float handBrake;" & @CRLF & _
"" & @CRLF & _
"public uint CarFlags " & @CRLF & _
" {" & @CRLF & _
" get => carFlags;" & @CRLF & _
"" & @CRLF & _
" set" & @CRLF & _
" {" & @CRLF & _
" if (carFlags == value)" & @CRLF & _
" return;" & @CRLF & _
"" & @CRLF & _
" SetProperty(ref carFlags, value);" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"public uint CarFlags2 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")