const regex = /a(?<!\bca(?=t\b))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a(?<!\\bca(?=t\\b))', 'gm')
const str = `I am a cat in a hat in a car" except where it appears in the word "cat":`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}