$re = '/^(?=[^A-Z\n]*[A-Z])(?=[^a-z\n]*[a-z])(?=[^0-9\n]*[0-9])(?=[^#?!@$%^&*\n-]*[#?!@$%^&*-]).{8,}$/m';
$str = 'abcA1#!A
#!asdfSFD1;
# a f F1 ;
1111111111
aaaaaaaa
11111111
AAAAAAAA
########';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);