import Foundation
let pattern = ##"<object[^>]*>.*?<\/object>|<span[^>]*>.*?<\/span>|<(?:object|embed|svg|img|div|span|p|a)[^>]*>|((\s|^)(\<3|<3|\<\/3|<\/3|\:'\)|\:'\-\)|\:D|\:\-D|\=D|\:\)|\:\-\)|\=\]|\=\)|\:\]|'\:\)|'\:\-\)|'\=\)|'\:D|'\:\-D|'\=D|\>\:\)|>\:\)|\>;\)|>;\)|\>\:\-\)|>\:\-\)|\>\=\)|>\=\)|;\)|;\-\)|\*\-\)|\*\)|;\-\]|;\]|;D|;\^\)|'\:\(|'\:\-\(|'\=\(|\:\*|\:\-\*|\=\*|\:\^\*|\>\:P|>\:P|X\-P|x\-p|\>\:\[|>\:\[|\:\-\(|\:\(|\:\-\[|\:\[|\=\(|\>\:\(|>\:\(|\>\:\-\(|>\:\-\(|\:@|\:'\(|\:'\-\(|;\(|;\-\(|\>\.\<|>\.<|D\:|\:\$|\=\$|#\-\)|#\)|%\-\)|%\)|X\)|X\-\)|\*\\0\/\*|\\0\/|\*\\O\/\*|\\O\/|O\:\-\)|0\:\-3|0\:3|0\:\-\)|0\:\)|0;\^\)|O\:\-\)|O\:\)|O;\-\)|O\=\)|0;\-\)|O\:\-3|O\:3|B\-\)|B\)|8\)|8\-\)|B\-D|8\-D|\-_\-|\-__\-|\-___\-|\>\:\\|>\:\\|\>\:\/|>\:\/|\:\-\/|\:\-\.|\:\/|\:\\|\=\/|\=\\|\:L|\=L|\:P|\:\-P|\=P|\:\-p|\:p|\=p|\:\-Þ|\:\-Þ|\:Þ|\:Þ|\:þ|\:þ|\:\-þ|\:\-þ|\:\-b|\:b|d\:|\:\-O|\:O|\:\-o|\:o|O_O|\>\:O|>\:O|\:\-X|\:X|\:\-#|\:#|\=X|\=x|\:x|\:\-x|\=#)(?=\s|$|[!,.?]))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p>:)</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)