package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^(\x00-\x7F,½)]`)
var str = `½ a b c d ! $ \ ~ ) _ + { } < > \r \n ⅓ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}