const regex = /robert (.+?) palmer(?:.* palmer)? sent for the boat/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('robert (.+?) palmer(?:.* palmer)? sent for the boat', 'gm')
const str = `robert eric palmer sent for the boat
robert eric william palmer sent for the boat
robert eric palmer palmer sent for the boat
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}