const regex = /^(?!.*(\S)(.*\1){3}[^1]?)[]zzSS[-^?!!.'''-*1{33}0066-]{60}\z/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(\\S)(.*\\1){3}[^1]?)[]zzSS[-^?!!.\'\'\'-*1{33}0066-]{60}\\z', '')
const str = `['0'z.1\\(3-.]Sz^-)]3}\\.(6^61)[(S}![!1'**6*z\\{}-{{?^3)!?S00?]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}