use strict;
my $str = 'src="/bitrix/templates/1c-bitrix-new/images/vlogo.png"
src="/bitrix/templates/1c-bitrix-new/images/16.png"
src="/bitrix/js/main/core/core_db.min.js?14328132264928"
href="/bitrix/js/main/core/css/core_image.min.css?14293595955405"';
my $regex = qr/(?:<link[^>]+components/bitrix|(?:src|href)=\"/bitrix/(?:js|templates))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}