#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){(?=[^}]*want)(?=[^}]*bracket)[^}]+}"
Local $sString = "{this is a}{string with text}{i want this bracket}{only}" & @CRLF & _
"{i want this}" & @CRLF & _
"{i this bracket}" & @CRLF & _
"{i want this bracket}" & @CRLF & _
"{gjddnsgwantjgnsagjbracket}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")