using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{(?=[^}]*want)(?=[^}]*bracket)[^}]+}";
string input = @"{this is a}{string with text}{i want this bracket}{only}
{i want this}
{i this bracket}
{i want this bracket}
{gjddnsgwantjgnsagjbracket}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}