re = /{(?=[^}]*want)(?=[^}]*bracket)[^}]+}/m
str = '{this is a}{string with text}{i want this bracket}{only}
{i want this}
{i this bracket}
{i want this bracket}
{gjddnsgwantjgnsagjbracket}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end